Jump to content




View New Content Help  
Photo
- - - - -

Vlc Thai Subtitles


17 replies to this topic

#1 A_Traveller

A_Traveller

    What do you want? Information. You're not going to get it.

  • Advanced Members
  • PipPipPipPipPipPip
  • 3,870 posts

Posted 2010-05-20 15:45:28

Given that we may be spending more time in for a few evening I was looking at adding some Thai subtitle tracks to some downloaded movies. English or similar [French etc.] all seem to work fine, even if I add them form another source which I'm doing for Thai.

However, either I get no text, or odd characters. I'm assuming it's to do with the coding [IIRC Thai has at least 3 options, under Windows].

Anyone have some advice or ideally a 'cheat sheet' to fix this?

Regards & TIA

#2 GmB

GmB

    Senior Member

  • Members
  • PipPipPipPip
  • 131 posts

Posted 2010-05-20 17:54:41

In the "Subtitles & OSD" section of VLC preferences you can set the encoding.
Auto is working fine for me but you can try to select Thai.

Edited by GmB, 2010-05-20 17:57:02.


#3 A_Traveller

A_Traveller

    What do you want? Information. You're not going to get it.

  • Advanced Members
  • PipPipPipPipPipPip
  • 3,870 posts

Posted 2010-05-20 18:15:17

Thanks, I've tried Auto and even the Thai setting which does something :) in that the characters [sorry about the typo in the sub-heading] change but they are still not Thai.

Any thoughts?

Regards

#4 thaimite

thaimite

    Super Member

  • Advanced Members
  • PipPipPipPipPip
  • 1,229 posts

Posted 2010-05-20 19:08:09

I have tried and failed many times to get VLC working with Thai subtitles (text style srt ssa etcnot graphic).
However I ave given up and for that reason I now use this software to play movies with these subtitle types

And before you ask, despite the name it does play movies of most types

#5 Daffy D

Daffy D

    Platinum Member

  • Advanced Members
  • PipPipPipPipPipPip
  • 2,027 posts

Posted 2010-05-21 17:22:03

Don't know if this will help but maybe worth a try

Control Panel - Regional Language Options - Advanced - from the drop down menu choose Thai.

:)

#6 clown

clown

    Senior Member

  • Members
  • PipPipPipPip
  • 113 posts

Posted 2010-05-22 01:29:12

Funny. I'm having the same problem right now. I'm trying to add subtitles from www.thaisubtitle.com and they're just showing as gibberish in VLC and also when converted to DVD format for my player through ConvertXtoDVD.

#7 thaimite

thaimite

    Super Member

  • Advanced Members
  • PipPipPipPipPip
  • 1,229 posts

Posted 2010-05-22 11:45:41

Don't know if this will help but maybe worth a try

Control Panel - Regional Language Options - Advanced - from the drop down menu choose Thai.

:)

This is my standard setting and it does not work for me. I have tried many suggestions on other forums such as installing extra fonts etc and could get none of them to work which is wy I decided to use a different player for movies with Thai subtitles.

#8 A_Traveller

A_Traveller

    What do you want? Information. You're not going to get it.

  • Advanced Members
  • PipPipPipPipPipPip
  • 3,870 posts

Posted 2010-05-25 20:02:45

Well someone doesn't love. Having tied the combinations, on 2 systems [1 Vista 1 Win 7] I'm still Thai subtitleless even trying the Jet software.

Weird.

Any other thoughts? {since the curfew seems set to go on and on and on]

Regards

#9 welo

welo

    Super Member

  • Advanced Members
  • PipPipPipPipPip
  • 1,045 posts

Posted 2010-05-25 21:47:52

If you can't find a solution with VLC you might try Media Player Classic. Goto Options -> Subtitles -> Font and select THAI in the second dropdown. MPC is included in the K-Lite Codec package.

welo

#10 A_Traveller

A_Traveller

    What do you want? Information. You're not going to get it.

  • Advanced Members
  • PipPipPipPipPipPip
  • 3,870 posts

Posted 2010-05-25 23:52:37

^ Thanks that's a thought, though have to admit I ended up at vlc because the web-consensus was that it was the preferred package. Used MPC for yonks. I'll download the latest mega pack on the morrow, and let you know.

Regards

#11 CrankyCarrot

CrankyCarrot

    Senior Member

  • Members
  • PipPipPipPip
  • 330 posts

Posted 2010-11-10 00:38:17

Well I did all that and none of it worked!

#12 lomatopo

lomatopo

    Star Member

  • Advanced Members
  • PipPipPipPipPipPipPipPip
  • 11,262 posts

Posted 2010-11-10 10:07:29

I still don't understand why people try to cobble together fansubs and AVIs when you can just get proper material from Thai-centric BT sites but... (Hey, I used to waste my time doing this too.)

This seems to be a known problem. I Googled "Thai Subtitles VLC" and got a ton o hits...

Found this...

You need to load a program name Sisulizer's Kaboom The Conversion Utility
at - http://www.sisulizer.com. This program will help you converted sub's file

after you get the program, open tab : File converter
Sourcd filename is your sub's file,
codepage group : MS-DOS; Code page: Code page 00874- MS-DOS Thai

just ignore the middle parts

On the bottom there are another Codepage group/Code page
for Code page group choose UNICODE; Code page: UTF-8

leave the box in front of Write BOM - blank
Mark the box in front of Word wrap and Change content-type
Then click covert.... the save as box appear and choose where your want to save
the converted file

Edited by lomatopo, 2010-11-10 10:08:12.


#13 CrankyCarrot

CrankyCarrot

    Senior Member

  • Members
  • PipPipPipPip
  • 330 posts

Posted 2010-11-12 15:12:21

On it...

#14 keemapoot

keemapoot

    Platinum Member

  • Advanced Members
  • PipPipPipPipPipPip
  • 2,203 posts

Posted 2010-11-12 15:43:07

I've also never been able to get VLC to work with Thai subtitles, but no problems with GOM player, which is also a free download and IMO, better than VLC anyway. You just use the subtitle explorer to find the subtitle file once you download the st. You can also adjust the speed of the subtitle, which is important, because in many cases, the timing is off. good luck

#15 CrankyCarrot

CrankyCarrot

    Senior Member

  • Members
  • PipPipPipPip
  • 330 posts

Posted 2010-12-12 15:59:54

I've also never been able to get VLC to work with Thai subtitles, but no problems with GOM player, which is also a free download and IMO, better than VLC anyway. You just use the subtitle explorer to find the subtitle file once you download the st. You can also adjust the speed of the subtitle, which is important, because in many cases, the timing is off. good luck


I have now pretty much ditched VLC entirely in favour of Gom.

Once I found out how easily I could customise the controls/hotkeys etc, and fix the res, it was pretty good. Just wish I could up the volume a little more. Even with the Normalizer boost enabled and everything maxed, it's still too quiet with headphones.

#16 eq2

eq2

    Member

  • Members
  • PipPip
  • 16 posts

Posted 2011-09-10 18:59:10

here is a web ap that converts subtitles from thaisubtitles.com into a format that is compatible with VLC:

http://grinninggecko...itle-converter/

#17 PattayaPete

PattayaPete

    Advanced Member

  • Members
  • PipPipPip
  • 35 posts

Posted 2011-09-11 19:07:25

I had problems for years trying to add Thai subtitles to existing videos. There are lots of different subtitle types and lots of ways to edit them and lots of ways to add them to the movie. You problem could occur at any stage of the process. What was always causing me problems was the Thai character set and encoding it correctly.

Here's what I do now and it always works.

Download the subtitles from wherever. Thaisubtitles.com is a good place.

Load them up in subtitle workshop to confirm timings are OK. They often are not but subtitle workshop has lots of tools to fix that. It's a free download form http://www.urusoft.n...oads.php?lang=1

I then use mkvmerge (another free download) to combine movie and subtitles into an mkv file. However there is a trick and it took me a long time to figure it out. If the subtitles are Thai then you must select the right charachter set. To do that click on the subtitle in the tracks, chapters and tags window. Make sure it is highlighted. Under that window, click on the format specific options tab. Select charset and choose windows-874 as the encoding - its almost at the bottom of the list. Go ahead and make your mkv file.

These files play with the correct subtitles in all players I have tried, including VLC.

#18 Metin

Metin

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 2012-04-19 14:17:28

# This is worked for Thai Subtitles for VLC media player 2.0.1 Twoflower

# When you find the Thai subtitle with srt extension, give exactly the same name with the movie

# as an example: If the movie name is mymovie DOT avi the subtitle has to be mymovie DOT srt - this way it starts automatically, other wise drag and drop the subtitle.

Under VLC media player the menu on the left top side, do the following:


Tools/Preferences/Subtitles & OSD/

Default encoding : Thai (TIS 620-2533/ISO 8859-11)

Font: Angsana New


Then click "save" button.


#You can try different Thai fonts or Thai (Windows-874) encoding

Good luck!





Sponsored by:

Quick Navigation  View New Content Site search: