Jump to content




View New Content Help  
Photo
* * * * * 1 votes

Samsung Galaxy S4 does not connect to home wifi


25 replies to this topic

#1 beano2274

beano2274

    Titanium Member

  • Advanced Members
  • PipPipPipPipPipPipPip
  • 6,512 posts

Posted 2013-06-23 19:33:23

Wife just bought herself a Galaxy S4, but when trying to use the wifi at home it does not work, it works with Samsung S2 and S Plus, read on some blogs this is a problem, but has anyone here actually got it to work.

 

Router is a Zyxel P600HW, and it is only at home, at her work it is okay.

 

Please answer in easy english if you know how to do it, as I have to pass this information on to her as am in Germany until next weekend

 

 



#2 lomatopo

lomatopo

    Star Member

  • Advanced Members
  • PipPipPipPipPipPipPipPip
  • 11,262 posts

Posted 2013-06-23 19:41:40

No problems here.

 

Maybe just check security protocol (WPA-PSK), pass-phrase, IP address conflicts.

 

Delete any APs, turn off WiFi router, re-start, turn off phone, re-start, add the AP.

 

I guess it could that your Zyxel unit is so ancient that it is causing problems?

 

Which blogs indicate this is an issue?



#3 beano2274

beano2274

    Titanium Member

  • Advanced Members
  • PipPipPipPipPipPipPip
  • 6,512 posts

Posted 2013-06-23 19:46:02

what is AP?

 

Many blogs on the internet about it, also wife's friend also has the same problem.



#4 bangkokrick

bangkokrick

    Remember this member

  • Advanced Members
  • PipPipPipPipPipPip
  • 3,129 posts

Posted 2013-06-23 19:52:46

An AP is an access point Beano.



#5 beano2274

beano2274

    Titanium Member

  • Advanced Members
  • PipPipPipPipPipPipPip
  • 6,512 posts

Posted 2013-06-23 19:54:26

at the moment she is phoning Samsung in Thailand to see if it works.



#6 beano2274

beano2274

    Titanium Member

  • Advanced Members
  • PipPipPipPipPipPipPip
  • 6,512 posts

Posted 2013-06-23 20:10:11

she told me she has done all the things above still does not work



#7 bangkokrick

bangkokrick

    Remember this member

  • Advanced Members
  • PipPipPipPipPipPip
  • 3,129 posts

Posted 2013-06-23 20:16:34

Could be router compatibility. You have a state if the art phone and an aged router. Could be worth upgrading mate.



#8 beano2274

beano2274

    Titanium Member

  • Advanced Members
  • PipPipPipPipPipPipPip
  • 6,512 posts

Posted 2013-06-23 20:28:10

borrowing another router to check, she is playing with it now



#9 bangkokrick

bangkokrick

    Remember this member

  • Advanced Members
  • PipPipPipPipPipPip
  • 3,129 posts

Posted 2013-06-23 20:31:39

borrowing another router to check, she is playing with it now

Yes good idea this will prove it either way.



#10 joncl

joncl

    Senior Member

  • Advanced Members
  • PipPipPipPip
  • 839 posts

Posted 2013-06-23 21:21:01

Sounds like the DHCP server on your home modem/router is not set up correctly, wife had the same problem here too and setting the modem router up correctly made it work fine (that is why it works OK at her work)  .. 



#11 beano2274

beano2274

    Titanium Member

  • Advanced Members
  • PipPipPipPipPipPipPip
  • 6,512 posts

Posted 2013-06-23 21:36:35

Sounds like the DHCP server on your home modem/router is not set up correctly, wife had the same problem here too and setting the modem router up correctly made it work fine (that is why it works OK at her work)  .. 

 

how did you do that?



#12 beano2274

beano2274

    Titanium Member

  • Advanced Members
  • PipPipPipPipPipPipPip
  • 6,512 posts

Posted 2013-06-23 21:47:19

seems like it was the modem, worked with the new one she got a connection and the password was accepted, so shopping time again.

 

Any recommendations for a good wireless Modem/Router except DLINK


Edited by beano2274, 2013-06-23 21:47:55.


#13 howard251

howard251

    Advanced Member

  • Members
  • PipPipPip
  • 37 posts

Posted 2013-06-23 22:41:36

I own a Samsung S4 and about 5 days ago I got a message about a firmware software upgrade which fixes a lot of bugs and makes the phone more stable. 

 

If you can connect using wifi 1 time in a coffee shop, public wifi, or 3G, and check for an software update in the "About Phone" setting in the phone, I believe it could fix your problem because your S2 connects just fine at home.

 

A screen snapshot I took from my S4 before I ran the update. This will give you an idea of what the update looks like.

 

https://dl.dropboxus...ware update.png

 

Good luck...



#14 steelepulse

steelepulse

    Beach Club

  • Advanced Members
  • PipPipPipPipPipPip
  • 4,697 posts

Posted 2013-06-23 22:49:43

I too have a problem with the same router and a new phone ( I started a thread in this section about this yesterday).  I'm thinking it's the router.



#15 rakman

rakman

    Senior Member

  • Advanced Members
  • PipPipPipPip
  • 978 posts

Posted 2013-06-24 04:24:37

I too have a problem with the same router and a new phone ( I started a thread in this section about this yesterday).  I'm thinking it's the router.

I wonder if someone set MAC security so only the "registered" (by MAC address) devices at your location will connect.  If you can log into the router, it's worth a check.



#16 lomatopo

lomatopo

    Star Member

  • Advanced Members
  • PipPipPipPipPipPipPipPip
  • 11,262 posts

Posted 2013-06-24 08:08:42

What security protocol are you using on the router?

 

You could, ever so briefly, turn off all WiFi security protocols (WPA/WEP) and open the router up. Then try to connect. If you can connect then it is an issue, probably with the router. Remember to re-enable any preferred WiFi security protocols.

 

Do you use DSL?

 

We've been using Asus DSL-N12U units in most of our recent True Online DSL installs. These units have been working perfectly.

 

http://support.asus....iGrkjRYX5CrIb07

 

 

and it is only at home, at her work it is okay

 

This would seem to support the contention that the issue is with your router?

 

 

 

problems we've run into:

 

Router supports up to channel 13 for WiFi, but some devices support up to channel 14. We usually do a quick scan of neighboring APs and choose a fixed channel on the router to avoid conflict, typically channels 2 or 3. Obviously this should be monitored; and adjusted. Many routers seem to default to ch. 11, and I've seen 10+ APs on ch. 11 in a single location.

 

Devices go in to sleep mode then try to use the same IP address they used before, which has subsequently been handed out to another device. Re-boot the device or the router or both.

 

When using WPA-PSK, two different encryption protocols can be used TKIP or AES, often there is a mismatch between what the device can support or is configured to support, and what the router can support or is configured to support. Newer routers have a TKIP+AES setting.

 

Devices store APs so it is advisable to flush out unused APs (e.g. PTT FreeWiFi@go.th  ;)  ) regularly: Settings, Wireless & networks, WiFi, press/hold and Forget.

 

 

I am currently supporting a True/DSL - Asus DSL-N12U install and the user got an SGS4 the first day it was available, so what a few months, and there have been no issues. This user just uses WiFi at home, and at work, and 3G elsewhere. I think they are prohibited from using any public WiFi on phones.



#17 Satcommlee

Satcommlee

    Super Member

  • Advanced Members
  • PipPipPipPipPip
  • 1,556 posts

Posted 2013-06-24 18:16:37

Check which Wifi channel your router is using..

 

A certain channel (I Think 13) is illegal in Thailand and your phone may know this.

 

Try changing the channel in the routers config, if this is the case.



#18 gr8fldanielle

gr8fldanielle

    Senior Member

  • Advanced Members
  • PipPipPipPip
  • 803 posts

Posted 2013-06-24 19:09:14

I have a Galaxy GT-P6800 7.7 tablet. when I upgraded the ROM to ICS (icecream sandwich) I first installed an ROM from the UK or somewhere. the only thing that didn't work was the wifi at home or anywhere else for that matter. When I finally found an ROM for Thailand/Malaysia.Vietnam and installed that, everything worked great.

I have read since that this is an issue, you need the ROM for the area you're in, I don't know about how that works when traveling.

hope this helps.



#19 jpduggan

jpduggan

    Senior Member

  • Members
  • PipPipPipPip
  • 288 posts

Posted 2013-06-24 19:38:14

Hope she didn't buy it in Tutcom?



#20 Pib

Pib

    Star Member

  • Advanced Members
  • PipPipPipPipPipPipPipPip
  • 10,094 posts

Posted 2013-06-24 20:01:06

The wife and I have S4's...they connect just fine to our home Wifi (a Thomson cable modem/router) and we use WPA2 security for the connection.   They connected fine right out of the box...we bought them at a DTAC service center....and there have been two minor firmware updates since with no problems.



#21 Cuban

Cuban

    Platinum Member

  • Advanced Members
  • PipPipPipPipPipPip
  • 4,254 posts

Posted 2013-06-24 20:12:41

Hope she didn't buy it in Tutcom?

 

And the relevance of this comment is? 

 

As I assume you mean http://www.tukcom.com



#22 retell

retell

    An always thirsty

  • Advanced Members
  • PipPipPipPipPip
  • 1,563 posts

Posted 2013-06-25 07:14:01

work the other way around , connect the router to the telephone



#23 steelepulse

steelepulse

    Beach Club

  • Advanced Members
  • PipPipPipPipPipPip
  • 4,697 posts

Posted 2013-06-27 20:34:08

On a tangent but semi relevant, I still can't get my POS home router to work with my phone, but I was at a friends pub and downloaded 100 megs in 1-2 minutes, so it's not the phone at least.



#24 lomatopo

lomatopo

    Star Member

  • Advanced Members
  • PipPipPipPipPipPipPipPip
  • 11,262 posts

Posted 2013-06-28 06:59:06

On a tangent but semi relevant, I still can't get my POS home router to work with my phone, but I was at a friends pub and downloaded 100 megs in 1-2 minutes, so it's not the phone at least.

 

Without any details my best guess would be that your router is not properly configured, or is not capable of supporting, the wireless security encryption protocols you are using on your phone.

 

You could re-configure your router to remove any/all WiFi (Wireless LAN) security protocols, then see if you can connect to your now "open" home WiFi network. You should be able to connect in this scenario - and if you can check back in for some next steps/options. Remember to re-enable any preferred WiFI security protocols.



#25 steelepulse

steelepulse

    Beach Club

  • Advanced Members
  • PipPipPipPipPipPip
  • 4,697 posts

Posted 2013-06-28 09:54:43

 

On a tangent but semi relevant, I still can't get my POS home router to work with my phone, but I was at a friends pub and downloaded 100 megs in 1-2 minutes, so it's not the phone at least.

 

Without any details my best guess would be that your router is not properly configured, or is not capable of supporting, the wireless security encryption protocols you are using on your phone.

 

You could re-configure your router to remove any/all WiFi (Wireless LAN) security protocols, then see if you can connect to your now "open" home WiFi network. You should be able to connect in this scenario - and if you can check back in for some next steps/options. Remember to re-enable any preferred WiFI security protocols.

 

 

Yes, I need to get the ISP out.  They have the router set so I can't make any changes unless I do a hard reset, but as I don't have the un and pw for the connection, I don't want to do this without the ISP here.  BTW, my protocol is WEP which I hear is not that good.







Sponsored by:

Quick Navigation  View New Content Site search: