Jump to content
BANGKOK 16 January 2019 08:19
thelynxxxx

BTC node: Port Forwarding working but no inbound connections

Recommended Posts

I'm trying to run a full BTC node on my Raspberry Pi (Raspbian) with a Huawei HG8247H router issued from True. Everything is up and running smoothly. However, as I would like to contribute to the network, I would like to allow inbound connections, not just the usual 8 outbound ones. I have set up a static IP for RPI and opened port 8333. I confirmed the port to be open using nmap. The problem is that I still only get 8 connections when I run

getconnectioncount

. I've been trying to figure this out for a couple of days now. Very frustrating. Does anyone have any suggestions? Thanks in advance.

Share this post


Link to post
Share on other sites
Posted (edited)

The limit is set to 8 regardless of whether you allow incoming connections or not.

 

There is a command line option to get around this : -maxconnections=25

 

It used to work this way, probably still does. This option affects inbound connection and the number of connections might not increase for days or even weeks.

 

From memory (going back years now) it can go into the .conf file as well.

Edited by ukrules

Share this post


Link to post
Share on other sites
17 hours ago, ukrules said:

The limit is set to 8 regardless of whether you allow incoming connections or not.

 

There is a command line option to get around this : -maxconnections=25

 

It used to work this way, probably still does. This option affects inbound connection and the number of connections might not increase for days or even weeks.

 

From memory (going back years now) it can go into the .conf file as well.

Thanks for your reply. I've already added the option -maxconnections=25 in my bitcoin.conf file. From what I understand, 8 is the maximum for outgoing connections, so if you only get 8 when you run the getconnectioncount command, it means you have no incoming connections. 

 

Thankfully, earlier this morning, I stumbled upon this website and it sorted me out. I now have 14 connections, which means incoming is open.

 

Cheers.

Share this post


Link to post
Share on other sites

It was tricky to set it up on my true "billion" brand router, even with the correct port open in the router control panel I wasn't getting any inwards connections and i had to call the technical support a few times and they tried to say it was open but it obviously wasn't and the tech guy they sent out couldn't get it to work either

 

Eventually got it working via a button i forget the name of that opens all  ports, something like the guy below, not the ideal solution but it was the only way i could get it to work

 

https://community.spiceworks.com/topic/1277482-how-to-set-up-port-forwarding-in-billion-router-bipac-8800nl

 

I don't know if they were initially blocking it at their end or not but when you get it you will see your node and uptime on

 

https://bitnodes.earn.com/nodes/?q=Thailand

 

 

 

Share this post


Link to post
Share on other sites

Thanks Ks45672; Not sure which router you're referring to . . . I've got the Huawei HG8247H. The route of opening all ports is a bit too risky in my view. At any rate, as mentioned, following the instructions here  https://thecryptostreet.com/blockchainnewsmagazine/blockchain-technology/how-can-i-setup-bitcoin-to-be-anonymous-with-tor/  

I was able to get it working using Tor. From the website: "No port forwarding is necessary for everything to work with Tor including incoming connections via the Tor hidden service, you do not need to forward any ports for Bitcoin Core or Tor for this." So it seems to solve the port forwarding issue though it took a bit of fiddling. It's been a couple days now and it appears stable . . . with 16 connections currently.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

Sponsors
×