Jump to content


This topic is now archived and is closed to further replies.


Wonder Media Wm8650 Tablet - Help?

Recommended Posts

My girlfriend returned from the Chong Chom market at the Cambodian border with the above tablet computer copy and as I'm not techie (and there's no instruction manual), I need to kindly ask for some help from the resident TV IT experts to find out exactly what she's got and what it can and can't do. More emphasis on the latter likely. Why she bought it, I don't know, but that's another story.

The info I have found out so far from the "about the device" section in "settings":

Model: WonderMedia WM8650

Android Version: 2.2

Kernel Version - default

Build Number: generic-eng 2.2 froyo Ver1.3.1 - 20110513.125040

It also stated that the internal storage space is 2GB. Exactly how much of the above is true, I'm not sure and don't know how to find out. I did find access to the Root and Parent directories but it's all gobbledegook to me.

I inserted a phone memory card into the USB port and the device succesfully plays music and views photos from the card. I then tried to set it up for the wireless internet network we have at home already and that's where I'm stuck. Wifi is switched to "on", (airplane mode not ticked) then when you go into set up, wifi has already switched itself off. A notification box for open networks is ticked and when I reopen the wifi, it gives the message "scanning", then within no time at all a message appears saying "unable to scan for networks" and the wifi automatically switches off again.

"Add Wi-Fi network" will only work when wifi is on for those few seconds, in which time I can't get the SSID and password in. I can save the details though and it appears to accept them but I can't see them anywhere. I can sit the device right next to the wireless router and nothing is being picked up before it switches itself off. My laptop and girlfriend's phone can both get signals outside so signal strength shouldn't be an issue. I tried plugging the device into the modem and keying in what I thought was my user name password to the ADSL settings and that didn't work either. Although I may have got the details wrong. But it's no use to me plugged into the wall anyway. There is also something similar to configure Ethernet but I don't know the relevance of that either.

It also supposedly good for 3G and there is facility to add a 3G Network. Albeit when you try to add the choices are WCDMA, CDMA2000 and TD-CDMA, which I thought were all 2G.... but I'm guessing there. I don't think we even have 3G where we live anyway and I'd rather get wifi working, so if anyone can point me in the right direction (even to confirm I've got a dud on my hands), then that would be very much appreciated. Would be great if it's just a setting that needs adjusted somewhere...............

If I can get something working with the internet I'll be a lot happier and might even venture into the land of custom ROMs. Whatever they are! Or perhaps I'll have to make do with a glorified picture viewer and mp3 player.

Thanks in advance for any help


Share this post

Link to post
Share on other sites

Challenging to trouble-shoot here but some guesses...

A quick Google search seems to indicate that the unit does indeed support WiFi. Maybe it's an "ad hoc" v. "infrastructure" setting issue? Or maybe the WiFi HW/FW has some issues? Can you "open" your WiFi (remove all WEP/WPA for a few minutes), then manually add the SSID on the WM 8650? (When in the WiFi settings there is an advanced settings menu, hit Settings a 2nd time to access it.)

Maybe grind through some forums/Youtube videos to get up to speed on this product?

FWIW, according to all the specs I find this unit does not support 3G.



Share this post

Link to post
Share on other sites


I have one of these tablets. And, use it when traveling.

A little history; the 8650 chip is second generation - adequate for internet browsing - and, non-HD video - a lot of these tablets from China - not an iPad clone - the hardware architecture is Chinese design.

Touch screen is resistive - use a stylus or a USBmouse (what I use).

Memory is 2Gig and 256 MB RAM.

The Android kernel will support some 3G modems.

As to your wifi problem, it may be that you are a victim of quick assembly. Peruse the boards of ROM modders for this tablet and you will see examples. Sometimes, it is simply that a wire has loosened from the wifi chip. It seems that a cheap price also means that the manufacturer feels the purchaser to be responsible for final assembly.

And, as a check of the tablet, I would suggest that you try try a wired network on the adapter. If you can surf, then the wifi card is probably the culprit.

Your model has the 1.3.1 build. The newest build is 1.5.3 and the increase in performance is significant. I started with a 1.3.1 build.

Okay, what to do with your tablet?

If you are not interested in self-installing ROM flashes or opening the case, then a visit to a computer shop is next. These tablets are selling in Thailand now. In Chiang Mai, the “OK Computer” store in Icon Square near Chang Pauk Gate sells them. A lot of them. And, they repair them. Opening the case requires a careful hand, but the components are either taped or held with screws.

If you want to flash or open the case then there is a wealth of information on slatedroid.com and u-Tube. Also, Google “Uberoid”. (That’s the ROM that I use - HcH, a brilliant hacker - information to identify tablets is on the forum).

Ordered my tablet direct from China. Very cheap. Didn’t expect much. Just wanted to play with Android and a tablet. And, have been quite surprised at what the tablet will do with a flashed ROM. Haven’t carried my laptop since.

Share this post

Link to post
Share on other sites

Thanks to both posters above for the replies. I've started ploughing through the linked forums in search of some pointers but must admit that most of it is over my head. Will persevere and perhaps start a new thread to see if anyone else had the same initial difficulties.



Share this post

Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

BANGKOK 23 January 2018 01:41