cdnvic

Using Thai With Your Computer

58 posts in this topic

Sometimes you can fix that by downloading the .xpi file to your desktop, then:

1. change the file extension from .xpi to .zip and unzip the contents

2. open up the .rdf file in Notepad

3. change the maxversion to the version of your Firefox eg 3.0.4 and save

4. zip up all the files again that you previously unzipped

5. change the extension back to .xpi

6 open up Firefox then drag the xpi file onto Firefox and follow the prompts thereafter.

thanks... i will try that and report back...

sounds a bit difficult for me though!

Share this post


Link to post
Share on other sites

You can get the stickers for your keyboard at any computer store here for like 30 baht. They typically come in two sizes, normal keyboard size and laptop size. The stickers last about two years before they wear out.

Go to the bottom of this page to download a butt load of Thai fonts:

http://www.learnthaiculture.com/thai_extras.shtml

Also, if you are on a computer that doesn't support Thai, use this to type:

http://www.learnthaiculture.com/thai_typer.html

Share this post


Link to post
Share on other sites

I hope my information below is not redundant.

There 2 ways to have Thai character in your computer

  1. If your computer is Windows XP, then you can enable the Thai character and switch between English and Thai; I provide the step-by-step instruction at the end of this posting, if you choose this method.
  2. Go to http://english-thai-dictionary.com/index.p...on=thaikeyboard and use the virtual keyboard to get the Thai character, which you want to type, then using the copy-paste to put it into your document/email.

I personally like the second method because my keyboard is not a Thai keyboard (hence I need layout of Thai keyboard printed on a paper) and I am too lazy to switch back and forth between English and Thai language (although it is a matter of 2 clicks or 2 buttons)

Step-by-step of enabling Thai character in Windows XP computer:

  • Make sure that you have your Windows installation CD handy
  • Open control panel
  • Double click on "Regional and Language Options" icon
  • Click "Languages" tab
  • Click "Details" button
  • Click "Add" button
  • Select Thai as "Input language" and "Keyboard layout"; For my computer, I selected both Kedmanee and Pattachote; I don't know what it is but it works well in my system until now
  • Click "OK" button in "Add Input Language" window
  • Click "Apply" button in "Text Services and Input Languages" window; You may need your Windows installation CD at this stage
  • Back to "Text Services and Input Languages" window, in "Setting" tab, you can select on how to switch between English character and Thai character by clicking "Key Settings" button

Somehow you may find that this step-by-step is still confusing, then please feel free to drop your questions here (please don't pm me), I'll try to answer it.

Share this post


Link to post
Share on other sites

anyone know how to isolate the thai language files on one computer so that they can be moved to another?

i do not have the windows disk with me anymore and the thai files therefore cannot be installed on my laptop. my desktop however, does have them already installed.

Share this post


Link to post
Share on other sites

Hello,

I just installed the thai language pack available from microsoft, but now, I have no idea of the way to go back to english. Can ayone help me?

Share this post


Link to post
Share on other sites

On the problem of Large Thai Script not working when Firefox is upgraded:

Sometimes you can fix that by downloading the .xpi file to your desktop, then:

1. change the file extension from .xpi to .zip and unzip the contents

2. open up the .rdf file in Notepad

3. change the maxversion to the version of your Firefox eg 3.0.4 and save

4. zip up all the files again that you previously unzipped

5. change the extension back to .xpi

6 open up Firefox then drag the xpi file onto Firefox and follow the prompts thereafter.

I've just had that problem with Firefox 3.6.3. The version (of 'Version 0.1') of the 'Large Thai Script' add-on I found (at Large Thai Script :: Firefox Add-ons for Firefox) had maxversion specified as 3.5.*. I changed that to 3.6.*, but it did not work. What did work was changing it to plain 3.7. (I didn't try upping it to 3.6.3, as on past form Firefox 3.6.3 will soon be replaced by Firefox 3.6.4)

Share this post


Link to post
Share on other sites

Thanks Richard, I've updated it on the Mozilla site now, up to the maxversion they allow it to be at present.

Share this post


Link to post
Share on other sites
I've just had that problem with Firefox 3.6.3. The version (of 'Version 0.1') of the 'Large Thai Script' add-on I found (at Large Thai Script :: Firefox Add-ons for Firefox) had maxversion specified as 3.5.*. I changed that to 3.6.*, but it did not work. What did work was changing it to plain 3.7. (I didn't try upping it to 3.6.3, as on past form Firefox 3.6.3 will soon be replaced by Firefox 3.6.4)

I had one extension I got to work recently by changing the maxversion to 99.0.*.

Share this post


Link to post
Share on other sites

I'm using Windows 7 pro, openoffice, and mostly tahoma thai fonts for my homework. When I print out a document, what should be ป่า prints out as ปา. In other words, it's dropping the tone mark. I suspect what's happening is that the tone is aligned to closely with the long part of the ป. I've tried a few other fonts (angsana upc, cordia new) with the same problem.

Prior to buying Windows 7, I was using MS Office and did not have this problem, so it's entirely possible that it's a problem related to openoffice.

Perhaps someone out there has had the same problem and knows of a fix??

All help appreciated.

Share this post


Link to post
Share on other sites

How can I get a Thai keyboard for Windows XP? I followed the instructions given before:

Step-by-step of enabling Thai character in Windows XP computer:

  • Make sure that you have your Windows installation CD handy
  • Open control panel
  • Double click on "Regional and Language Options" icon
  • Click "Languages" tab
  • Click "Details" button
  • Click "Add" button
  • Select Thai as "Input language" and "Keyboard layout"; For my computer, I selected both Kedmanee and Pattachote; I don't know what it is but it works well in my system until now
  • Click "OK" button in "Add Input Language" window
  • Click "Apply" button in "Text Services and Input Languages" window; You may need your Windows installation CD at this stage
  • Back to "Text Services and Input Languages" window, in "Setting" tab, you can select on how to switch between English character and Thai character by clicking "Key Settings" button

Somehow you may find that this step-by-step is still confusing, then please feel free to drop your questions here (please don't pm me), I'll try to answer it.

The problem is here:

Select Thai as "Input language"

it's not there! On my computer (German version of Windows XP) I have Tartarisch, Tschechisch, Tswana, but no Thai! I checked on two different computers with German Windows and one computer with French Windows, Thai is missing on all of them!

I'm close to touch-typing Thai (means I don't need a keyboard Thai/English or Thai stickers). So far, I used the Thai keyboard on womenlearnthai, but I want to type Thai without internet and switch between German and Thai with "Alt" + "Shift" as I do between German, English, French, Dvorak and Russian.

Share this post


Link to post
Share on other sites

ID: 36   Posted (edited)

Thanks to a private message with the following link I finally got it.

http://office.micros...P010039424.aspx

The correspondent menue is only accessible via the "start" button and the control panel (not via the language bar). This left one problem: the computer I use is second hand, and I don't have the Windows-CD!

I was hoping installing Thai just requires one file, so I searched and found the required file on the internet, but then another file was required, so I gave up after I read on some forum that about 200 files in five folders are necessary to install additional languages.

But my computer at work has a folder i386. I copied this on an USB-stick and gave this path instead of the CD-drive, and it worked! Now I am finally able to switch keyboard to Thai.

Edited by ChristianPFC

Share this post


Link to post
Share on other sites

For iPad users --

Home Screen

Settings

General

Keyboard

International Keyboards

Select a language you want to add

Done!

Once you're ready to type but want to switch the language on the virtual keyboard, look for the "global" icon located between the numeric and space keys.

Share this post


Link to post
Share on other sites

Hope this isn't considered advertising against forum rules, but if you want somewhere to practice and test your Thai typing skills then you can try at http://www.typeinthai.com/ (it's free). There's also what I think is an easier to use virtual keyboard than others mentioned here, as you just type and it's converted to Thai for you.

Share this post


Link to post
Share on other sites

I use the Thai characters as much as possible when making notes or flashcards, but I haven't grasped all the tone rule explanations. So, as a backup. I write romanised words with the tone marker character eg ^ = falling tone when writing by hand. I tried to use the special alt character set to put these above the relevant letter, but finding it difficult. an explanation from here http://www.theworldo...iacriticalmarks says use alt + 0710 to put ^ above a letter. I couldn't get it to work. The explanation talks about an International keyboard but I have the typical laptop layout for Thailand with Romanised and Thai characters. I'm using Windows 7 with Google Chrome browser - all I get is the 'Ping' - what are you doing you idiot? - sound!

Please have pity if I've missed the obvious.

Share this post


Link to post
Share on other sites

A nice Windows free application to convert to Thai font some computer unreadable writings if you dont have the Thai fonts installed : XTIS620.

S.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

BANGKOK 30 May 2017 08:30
Sponsors
  • Popular Now